Ubuntu apt-get update Could not get lock/var/lib/apt/lists 错误

  • ubuntu,apt-get,update,
  • 2014-08-01 13:20:11

刚才用apt-get update 的时候报了这么一个错误。

binkery@binkery:/var/lib/apt/lists$ sudo apt-get update
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/<br /><br />

解决办法:

1 结束进程

ps -e | grep apt

找出现在正在是不是有apt进程在运行。有的话就kill掉。没有的话,那有可能就不是这个问题了。

sudo killall apt-get

2 . 删除 /var/lib/apt/lists/lock 这个目录。

sudo rm /var/lib/apt/lists/lock
或者
sudo mv /var/lib/apt/lists/lock /其他目录
然后
sudo apt-get update

这个时候就OK 了。

收工。

相关文章

- EOF -

本站文章除注明转载外,均为本站原创或编译。欢迎任何形式的转载,但请务必注明出处,尊重他人劳动。
转载请注明:文章转载自 Binkery 技术博客 [https://binkery.com]
本文标题: Ubuntu apt-get update Could not get lock/var/lib/apt/lists 错误
本文地址: https://binkery.com/archives/248.html

赞助商
网站统计
  • 网站运行:3279 天
  • 文章总数:736 篇
  • 网站统计